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1 OVERVIEW 
The Multi Point Editor is a Windows based utility, which allows the user to open, view, edit and 
save field correction files (.gcd or .fc3 files) and power correction files (.pc3). Optionally, the con-
tents can be copied into the clipboard, from where they can be pasted into other applications, 
such as spreadsheet programs, for further analysis. 
 
NOTE:  
The manual version 1.1.15 applies to the Multi Point Editor software from version 8.0.26 on. 

2 INSTALLATION AND LICENSE 
NOTE: Once using the RAYGUIDE application software, the Multi Point Editor feature is embed-
ded per default and does not need to be installed additionally. 
 
1. First install the RAYLASE PRODUCT INSTALLER (RLPI, free of charge): 

https://www.raylase.de/en/products/software/product-installer.html 
2. In the window "Select the targeted software configuration", select Multi Point Editor with the 

appropriate version.  
"View Change Log" shows an overview of the latest changes compared to the previous ver-
sion. 

 

3.  After you have agreed to the license agreement, the installation starts directly. 

 

Since the Multi Point Editor Application is a freeware, you do not need to purchase any license to 
use the software. 

https://www.raylase.de/en/products/software/product-installer.html
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3 FILE OPERATIONS 

3.1 Loading field and power corrections 
The user has two options to load corrections: 
 First, the user can open an existing *.gcd, *.fc3 or *.pc3 file via File > Open.  

For gcd files, if in the same directory the description file with a *.txt extension exists, then it 
will be loaded as well and important parameters such as the field size are extracted. 
If no such *.txt file exists, the user will have to manually set the field size. 

 Second, the user can import a *.txz file via File > Import. This is a text-based description of 
the corrections, which the application will parse. 

Additionally all supported files can be opened from the explorer via drag and drop or Open 
with… from the context menu. 

 

3.2 Saving field and power corrections 
The user can save the field or power correction value either to the same file, and thus overwriting 
the previous contents, or alternatively save the corrections to a new file. In this case, the applica-
tion will write a new description file (with a *.txt extension, only for *.gcd). 
Furthermore, the application does not create backup files. The user, thus, must either save to a 
new file, or manually create backups if so desired. 
If the resulting field with the applied correction exceeds the field size, you will be notified that the 
correction values will be clipped to match the field size. 
If “Create backup” is enabled in the settings (Edit > Settings), a copy of the correction file will be 
created at the provided backup path. An index will be appended to the filename, if the target file 
already exists. 
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3.3 Generating field corrections (3D) 

 

You can generate a field correction file for a 3D scan head. Therefor you can either import a 
scan head configuration file (*.cfg), or type in the data yourself.  
In addition you have to supply the number of desired layers for each dimension, e.g. 257*257*17 
for *.fc3 or 65*65*1 for *.gcd. 

3.4 Generate Power Correction 

 

To generate an empty Power Correction file (*.pc3) select File > Generate Fs.  
After defining the dimensions and the field size a new power correction file will be generated. All 
correction values of the new file will be 1 (100%).  
If a sub field is used and “No power outside subfield” is checked, only the cells within the sub 
field are set to 1. The rest is set to 0. 
To manipulate the table, use the Measurement > New Table Dialog to create a new Measure-
ment Table (see chapter 5.4.3). 
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3.5 Import Corrections 
Correction can be imported from *.txz files. The following parameters are read from the header 
(not case sensitive): 
 Head parameters: 

 Aperture 
 FocalLength 
 MaxLensTravel 
 XYMaxGalvoAngles 
 ObjToX 
 XToY 
 Yrad 
 Workingdistance 

 FocusShifter ( 0 or 1) 
If set to 1, the corrections for the z axis will be shifted, so that the middle of the z-axis is in the 
middle of the lens translator ( 32768 bit ) 

 4D ( 0 or 1) 
Activates the import of the 4th dimension ( for zoom ) 

 ExtensionAxis ( 0 or 1) 
If set to 1, only the data for the Z axis is read, and will be merged as extension axis to the ex-
isting correction. That means that before importing the extension axis, a field correction must 
be loaded 

 
The last line of the header must be “start”. 
The data is expected in the following order: 
POSITION X, TILT ANGLE X, POSITION Y, TILT ANGLE Y, POSITION Z, LENS 1 SPACING 
(EDGE), LENS 1 SPACING (CENTRE), LENS 2 SPACING (EDGE), LENS 2 SPACING (CEN-
TRE), SPOT, corrected SPOT 
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4 FIELD CORRECTIONS ANALYSIS 

4.1 Viewing field corrections 

 

The application’s main view consists of the following components: 
 The title shows the filename if one has been loaded. A star (*) indicates whether the data has 

been modified, i.e. is dirty. 
 Tabs in the top-left: the tabs Measurements (not for .pc3) and Corrections select whether the 

data grid is showing the multi point measurements or field correction values, respectively. 
The tab Graph shows a visualization of the data. 

 Below are tabs providing a choice of which axis should be displayed in the data grid. 
 Measurement data grid: the user can enter the position where the grid point was marked, in 

millimetres. 
 Field correction data grid: For each grid point, the field correction values are displayed in 

units of bit. The data is framed by the grid point’s coordinates for X in the top header and Y in 
the left-most column, respectively. All units are in millimetres. 
The grid point coordinates are derived from the field size. 

 Power correction data grid: for each grid point the power correction values are displayed as a 
factor from 0 to 4, meaning the power supplied by the laser has to be multiplied by the factor 
to get a consistent power distribution. 

 Footer: the status bar displays the correction type, such as Standard16 – which is the proper 
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type for regular 2 or 3 axis scan heads using conventional galvanometer technology. Further-
more, the field size and dimensions are shown. 

 If the correction file consists of multiple layer, e.g. a *.fc3 file, a slider for layer choosing ap-
pears on the left side of the window 

 If the correction file consists of multiple magnifications, an additional slider selecting the mag-
nitude appears on the left side of the window 

 The number of axes to select depends on the correction file, the maximum of supported axes 
is 5: X, Y, Z, ZoomZ, SensorZ (Auxiliary axis for e.g. Camera)  

 The unit of the displayed corrections can be selected in the settings (Edit > Settings), the re-
sulting range is: 

 

 16 bit 20 bit Percent 

Min -32768 -524288 -50 

Max 35767 524287 50 
 

4.2 Copying data to clipboard 
The entire field correction data for all three axes can be copied to the clipboard. The data can 
then be pasted into other applications, for example a spreadsheet program, for further analysis, 
or for example to create a 3D plot. 
In order to ease further processing, the data can be copied into the clipboard in two different for-
mats: 
 List Format 
In order to choose the list formatting go to Edit and make sure that the menu item “Format cop-
ied corrections as list” is checked. 
Description: 
Each grid point produces one line, which consists of the grid point’s X and Y coordinates, then 
the correction values for X, Y and Z. 
 
Example: 
 

Row/Column 0/0 represents the bottom-left corner 
 
Row Column Field X Field Y Field Z 
0 0 2407 296 0 
0 1 2283 330 0 
0 2 2162 363 0 
… 
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 Table Format 
In order to choose the table formatting go to Edit and make sure that the menu item “Format cop-
ied corrections as list” is unchecked. 
Description: 
Each axis produces a section, which itself consists of the corresponding field correction values 
arranged in rows and columns. The data is thus organized in the same fashion as seen in the 
data grid. 
 
Example: 
 

Top-Left item represents -X / +Y 
Top-Right item represents +X / +Y 
Bottom-Left item represents -X / -Y 
Bottom-Right item represents -X / -Y 
 
X Correction 
2407 2283 2162 2046 1934 1827 1723 1624 1528 1435 … 
2316 2194 2076 1962 1853 1748 1647 1550 1457 1368 … 
2227 2107 1992 1881 1774 1671 1573 1479 1388 1301 … 
… 
Y Correction 
-296 -330 -363 -394 -424 -454 -482 -510 -536 -561 … 
-227 -260 -292 -323 -353 -381 -409 -435 -461 -485 … 
-164 -196 -227 -257 -286 -314 -340 -366 -391 -415 … 
… 
Z Correction 
0 0 0 0 0 0 0 0 0 0 0 … 
0 0 0 0 0 0 0 0 0 0 0 … 
0 0 0 0 0 0 0 0 0 0 0 … 
… 
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4.3 Graphical visualization 
On the Graph tab, a visual representation of the correction file is displayed. You can zoom using 
the mouse wheel and browse through the layers via the slider on the left side. 

4.3.1 Field correction 

 

Colours from green (minimum) to red (maximum). Depending on the selected correction unit, the 
range is: 
 

 16 bit 20 bit Percent 

Min -32768 -524288 -50 

Max 35767 524287 50 
 

If a zoom or camera axis is present, the source for the displayed colour can be chosen. 
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Using the max contrast feature adapts the colour range to the actual Z range. Green will be used 
for the lowest and red for the highest Z value. 

 

4.3.2 Power correction 

 

Colours from green (correction factor = 0) to red (correction factor = 4) 
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5 FIELD CORRECTION 

5.1 Setting standard field size 
When the user opens a correction file (*.gcd) the application tries to load the corresponding de-
scription file (*.txt), which if available must exist in the same directory as the gcd. The description 
file contains parameters to calculate the field size. In case of the *.fc3 file, the description file is 
obsolete, as the information is contained in the *.fc3 file. 
In case the description file is missing, the user can manually set the field size via Edit > Change 
Field 
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5.2 Defining custom field 
Customers who wish not to use the entire field can define a smaller section – in the following re-
ferred to as “sub field”. The sub field does not need to be centred, but could be offset providing it 
is fully contained within the regular beam field. 
Open the “Define Field Parameter” dialog via Edit > Change Field 
The field size refers to the size the scan head is capable of covering, and is the one used to gen-
erate the field correction file. This value must match the value extracted from the correction’s de-
scription file – if existent. 
To define a custom field check “Define Sub Field” and enter the desired sub field size. If the sub 
field is shifted relative to centre then enter the appropriate values. Otherwise, leave them at 0. 
Customers who operate with a custom scan head have to enter the maximum scan angle of 
each galvanometer. 
Check “Specify Non-Standard Scan Angles” and then enter the mechanical maximum scan an-
gles. 
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NOTE: 
These sub field parameters merely affect the measurement locations used by this tool. The cor-
rection points outside the sub field will also be updated, but as the correction values will be ex-
trapolated, the accuracy may suffer.  
If the sub field changes for any reasons then you will need to recalibrate, i.e.: 
 Mark a new correction pattern at the desired region 
 Launch the Multi Point Editor 
 Load the correction file 
 Define the custom field 
 Enter the actual coordinates of the marked gridpoints 
 Apply the measurements 
 Save the correction file 
 Send the updated correction file to the controller card 
 
The sub field definition is getting saved, and will be loaded when opening a correction file with 
die same field size. 
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5.3 Circular sub field 
The sub field can be either rectangular or circular. Setting the “circular filed” option in the “Define 
field parameter” dialog changes the shape of the sub field to an ellipse defined by the size and 
the offset of the sub field. Furthermore, the size of the circle can exceed the size of the original 
field. This can be useful for a circular field which is covered by multiple deflection units. 

 

Fig. 1: Circle within main field / Circle exceeding main field. 

As the measurement table is still rectangular, not all values have to be filled. All cells that corre-
sponds to grid points outside the circle are crossed out and will be extrapolated.  

 

Fig. 2: Sample for circle field using 5x5 points 
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Fig. 3: Sample for quarter circle field using 9x9 points 

The table shows only the cells of the subfield being inside the original field. As a good portion of 
the circle is outside the original field, the table is reduced from 9x9 to 6x6 points. 

5.4 Entering errors 
5.4.1 Field correction 

 

By selecting the “Measurements” tab the user is presented a table which allows entering the ac-
tual mark positions for X and Y. 
Unless the user has defined a custom beam field, i.e. a sub field, then two coordinates are 
shown for every expected grid point: 
The coordinate on the top shows the expected position relative to the sub field. For example, if 
you have a 700mm x 600mm sub field then the left/right and bottom/top extreme grid points are 
located at +/- 350mm and +/- 300mm, respectively. 
The second coordinate (beneath in parenthesis) shows the expected position relative to the en-
tire beam field. For example, if the sub field is shifted by 15mm and 10mm in X and Y, then for 
the aforementioned sub field the corner grid points are expected to be located at -335/+365mm 
(X) and -290/310mm (Y). 
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The recommended procedure to fine-adjust the field is by marking a grid that coincides with the 
field correction’s grid points. For RAYLASE products the default grid consists of 65 x 65 (*.gcd) 
or 257 x 257 (*.fc3) rows and columns. Thus, for *gcd the dimensions of each cell are the field 
size divided by 64 (65 minus 1). For example, for a 160mm field each cell is 2.5mm x 2.5mm 
large. 
Once the grid has been marked, the actual cross points must be measured and their coordinates 
must be entered into the corresponding X and Y tab. 
If the measurements are not done by automation but done by hand, then it will tend to be rather 
laborious. For this reason, it is possible to set the error table to a subset and make the data entry 
much more manageable. 
By selecting Measurement > New Table the user can resize the error table to fit their needs: 

 

It is recommended to use a grid wich has its grid points on the grid points of the correction file. 
This can be achieved with the folling number of columns/rows: 3, 5, 9, 17, 33, 65, 129, 257. 
 
Be sure to select the Error Interpolation as Calculation Mode. For the Absolute Interpolation see 
chapter 5.14 Setting Field Correction directly. 
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In case of multi-layer corrections (*.fc3), the number of layers can also be defined. 

 

Furthermore, the specific layers for the measurement can be chosen. For example the Z field 
size is from 0 to -99mm. If you choose to measure three layers, the default selection of the layers 
will equidistant, in this example the layers z=0mm, z=-50mm and z=-99mm. With the Layers se-
lection boxes, you can define any three layers to be measured. But keep in mind that the accu-
racy may suffer, especially if the top and the bottom layer is not included. 
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5.4.2 Z-Axis Correction 
To calibrate the Z-Axis, chose Z-Line for the calculation mode in the new table dialog. The Delta 
Z value defines the multiplier for the calibration values to enter. It is provided as  mm on the lens 
translator module. 

 

 

The values will be multiplied by Delta Z, then interpolatet to fit the dimensions of the correction 
file and finally added to the Z correction values. 
If you marked the z calibration pattern, the values represent the lines starting from the center 
lined. E.g. the line 2 left from the center is -2, the line 3 right of the center is 3 and the center line 
is 0. 
See chapter 6.3 for how to mark a z calibration pattern. 
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5.4.3 Power correction 
For the power correction, the approach is similar to the field correction. Instead of measuring the 
distances, you type in the desired scaling factors from 0 to 4. 
In the following example, the power of the left and right border will be scale by 1.3 to 1.5 and the 
rest of the field will be scaled by 1.1. 

 

5.4.4 Missing cells 
Cells in the measurement table can be ignored for the error analysis. This can be useful if the 
grid point cannot be marked or evaluated at this position. In order to mask the cells, right click on 
the selected cells in the table and choose “Toggle ignored cells”. It will cross out the cells in red 
and the values will be ignored during analysis. 

 

Cells will also be ignored, if a circular sub field is used, and the cell is outside the circle. These 
cells are crossed out in orange and cannot be toggled. 
Both methods can be combined, but each row and column must have a least one value. 

 

Fig. 4 Ignored by cirular sub field / Ignored by circular sub field and mask 

Cells within the fileld should should only be ignored scarcely (e.g automated measering failed, 
sensor on position to measure). If to many cells are missing, the calibration result will suffer. 
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5.5 Loading measurements 
5.5.1 Measurement table types 

The measurement table supports the following types: 
 Error: This is the default type. The values define the actual position [µm] of the laser. 
 Edit: Direct input mode. Correction values will be replaced by the provided values [°/µm]. Cur-

rently only z axes are supported. 
 Offset: Values [bit] will be added to the correction values. 
 Scale: Correction values will be multiplied by the provide scale. Used by power calibration. 

5.5.2 Loading whole table 
The measurements table can be loaded from a text file, which can be generated with a text edi-
tor, or by any customer-supplied external program or by the Multi Point Editor itself (if the user 
previously saved the measurement table). 
Choose Measurement > Load Table in order to select the text file that should be loaded. 
This text file must comply with the following format: 
 Lines that should be ignored must begin with ‘#’ or be blank 
 All other lines are treated as valid data 
 The coordinates in each valid line must be separated by tab, space or ‘;’ (semicolon) 
 The coordinates must obey the US-English numbering style, i.e. ‘.’ (dot) as the decimal point 
 If the header line contains “layer” the first column will be interpreted as layer. If it contains 

magnitude and layer, the first column is magnitude, the second layer. 
Example: 
 

# Multipoint FieldCorrection File 
# The data contained herein describes the actual positions where the laser fired 
# All units (except for row and column etc) are in microns 
 
# Each line lists one data point consisting of 
# [Magnitude/Layer/]Row/Column: the position where the data point is expected expressed as [magni-
tude/layer/]row/column 
# ActualX/Y/Z: the position where the laser truly fired 
# Empty lines and lines that begin with '#' are ignored 
# The fields can be separated by <space>, <tab> or semicolon 
# The floating point values must use '.' as the decimal point 
 
; Type: Error 
; FieldSize: 250000 250000 
; SubFieldSize: 100000 100000 
; SubFieldOffset: 40000 50000 
; IsCircularField: True 
 
; Magnitude [] Layer [] Row [] Column [] ActualX [um] ActualY [um] ActualZ [um] 
0 0 0 0 -49000 -49500 0 0 0 
0 0 0 1 0 -51000 0 0 0 
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0 0 0 2 50010 -50000 0 0 0 
0 0 1 0 -50000 0 0 0 0 
0 0 1 1 0 0 0 0 0 
0 0 1 2 50000 0 0 0 0 
0 0 2 0 -53000 50000 0 0 0 
0 0 2 1 0 51000 0 0 0 
0 0 2 2 51000 50500 0 0 0 

 

Like shown in the example, the type can defined by “;Type: actualType”. The type can be Error, 
Edit, Offset or scale. If no type is provided, it defaults to Error. 
If the definition of the sub field is provided like shown in the example, it will be automatically 
loaded. Loading of table for a correction file with a different size than the one provided by the 
field size line will result in an exception to prevent misuse. If the field size is not provided, no vali-
dation is done. 
For multiple layers, if specific layers are chosen, they can be saved as Selected layers: followed 
by the layer numbers starting with 0 for the bottom layer. 
Multi-layer example: 
 

; Selected layers: 0 4 16 
 
; Layer [] Row [] Column [] ActualX [um] ActualY [um] ActualZ [um] 
0  0 0  -70040  -70490  10020 
0  0 1  -35180  -70490  10025 

 

The same logic applies to selected magnitudes. 
Missing cells are visualized by a red stroke and will be ignored when applying the table. They 
can be filled manually by using the context menu and choosing “Toggle ignored cells” (see 5.4.4 
Missing cells). 

5.5.3 Loading table layer 
Instead of loading the whole table, a single layer can be loaded with Measurement > Load Table 
Layer. This will only overwrite the data of the active layer of the measurement table. 
The file format is the same, but is can only contain a single layer and the number of rows and 
columns must be the same as the current measurement table. 

5.5.4 Importing List 
In case the measured points are not a grid, a list of measured points defined by expected and 
actual position can be imported. 
Unit of measure is µm and decimal point is ‘.’, as explained in 5.5.2 Loading whole table. Lines 
starting with ‘;’ ore ‘#’ are skipped. Supported formats are: 
 <expected X>, <expected Y>, <expected Z>, <actual X>, <actual Y> 
 <expected X>, <expected Y>, <expected Z>, <actual X>, <actual Y>, <actual Z> 
 <layer>, <expected X>, <expected Y>, <expected Z>, <actual X>, <actual Y>, <actual Z> 
 <magnification>, <layer>, <expected X>, <expected Y>, <expected Z>, <actual X>, 

<actual Y>, <actual Z> 
Indices of magnification and layer can be provided optionally. Currently only X/Y errors can be 
imported, meaning actual Z has to be equal to expected Z, if provided. 
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A new measurement table is created with the same number of X/Y points as the field correction. 
Number of layers and magnitudes are used as provided by the imported data. 
For each point of the measurement table, the nearest three points of the imported points are de-
termined. The error at this position is then defined by a plane fitted through the measured devia-
tion of these three points. 

5.6 Saving measurements 
The measurement table can be saved to a text file either to archive the measurement data or for 
further analysis by an external program. 
Choose Measurement > Save Table. 

5.7 Evaluating measurements 
There a two plotting modes available to visualize the measured data. To show the graphs, click 
on the Show Graph button, located next to the Apply button in the measurements tab.  

 

The type of the graph can be selected in the lower left corner. 
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5.7.1 Error Cloud 
The error cloud displays the necessary XY correction of each measured point. The color is de-
fined by the distance of the measured point to the center, meaning the color changes from green 
(center) to red (corner). The scale of the plot is shown as Plot size [µm] in the lower right corner. 

 

5.7.2 Error Vector 
The error vector graph shows the measured and the expected location. 

 

The measured points are green, the expected points blue. The resulting correction is displayed 
as a red arrow. 
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5.8 Applying scale 
In order to quickly resize the field size, the user can apply a scale factor to the entire field correc-
tion table. Since the scaling is applied to the field correction table, only minute scale errors 
should be entered. Larger scaling should be implemented by scaling every vector sent to the 
card. 

 

5.9 Apply offset 
To apply a constant offset to the X, Y or Z correction values, you can use the Correction > Apply 
Offset dialog. The same offset will be applied to all layers. 
Unit of measure controls if the offset is applied in field coordinates (mm) or control value (20 bit). 

 

5.10 Apply rotation 
To apply a rotation to the correction, choose the Correction > Apply Rotation dialog. The correc-
tions will be rotated by the specified value in positive direction (counter clock wise). It should only 
be used for compensating small (single digit) rotations. 
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5.11 Apply trapezoid 
To compensate a trapezoid shaped distortion, select Correction > Apply Trapezoid. After the axis 
to compensate is chosen, the measured sizes can be set. For the X Axis, the top and the bottom 
side has to measured and for the Y axis the left and the right side like shown on the picture. 

 

 

5.12 Interpolate correction 
Choose Edit > Change Dimensions to change the size of the corrections matrix. The missing val-
ues will be interpolated (non-linear). 
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5.13 Edit Header 
The Change Header option is only available for *.fc3 files. In the header are multiple optical 
parameters and some informational parameters stored. 
For example, RAYGUIDE is using the following parameters: field size, z offset, max lens travel, 
working distance and aperture. 
Some parameters cannot be changed and are only for information like the dimensions of the 
correction and the enabled axes.  

 

5.14 Setting Field Correction directly 
To set the Field Correction directly, go to Measurement > New Table and select the Absolut In-
terpolation mode. Tick the axes to be updated (currently only the Z-Axis is supported) and set 
the Max Lens Travel to the correct value if the Z-Axis is getting updated. 
The measurements table can be defined the same way explained in 5.4.1 (Measurement > 
New Table). 
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The Values are now displayed in millimetres and can be edited directly. By applying the 
changes, the values will be interpolated to fit the size of the correction table and replace the orig-
inal correction values of the chosen axis. 
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6 MARKING OF CALIBRATION PAT-
TERN 

6.1 SP-ICE-3 Connection 
To connect to your SP-ICE-3 card, go to the Marking tab and press the Discover button. All 
cards installed in your pc or connected to your LAN will be listed. Choose your card and press 
Connect. The address of the card will be saved and restored in further sessions. 

 

After the connection has been established, the active correction file will be sent to the card. If the 
correction file is changed or an other correction file is loaded, it will be sent to the card again. 
Please note that only the saved files can be sent. Any unsaved changes will not be sent to the 
card. 
The SP-ICE-3 field transformation set by another application can be red back and applied to the 
correction file. If the transformation is not identity matrix, you will be asked if you want to update 
the correciton file. 
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If the correction file was updated, it has to be saved, for beeing able to send it to the card. 

 

After skipping or appliing the transformation, it will be reset on the card. 

6.2 XY-Axes Calibration patterns 
There are five different pattern for calibration the XY coordinates.  
As recommended in chapter 5.4.1 Field correction, the measurement grid should have its grid 
points on the grid points of the correction file. This can be achieved with the following number of 
columns/rows: 3, 5, 9, 17, 33, 65, 129, 257. 

6.2.1 XY Grid 
The XY Grid is the best choice for manual measurement. It will mark a grid with the specified 
amount of grid points. For convenience, the axis and the grid points can be labelled.    
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6.2.2 XY Drill 
The XY Drill pattern is similar to the XY Grid pattern, but instead of marking a grid, the grid points 
will be drilled with the specified pulse count. The Highlight center will drill four additional point to 
identify the center. They are placed on half way between the center and the adjacent points. The 
mark delay will be inserted after each drill. 
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6.2.3 XY Circle 
The circle pattern marks a circle with a defined radius at each grid point. 

 

As a circle can’t be marked at the edge of the field, it will be cut off. To avoid the circles being cut 
off, a sub field can be defined. 
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The following picture shows the same pattern for a sub field of 240 mm instead of the original 
250 mm of the correction file. 
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6.2.4 XY Cross 
The cross pattern marks a cross at each grid point. 

 

Optionally the cross can be surrounded by a box. 

 

Like explained in the circle pattern, this pattern will be cut of at the edge of the field. Choose a 
sub field to avoid this behaviour. 
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6.3 Z-Axis calibration pattern 
The Z-Axis calibration pattern will mark several lines at each grid point. Each lines subtracts or 
adds the offset defined by Delta Z in mm to the z-axis. The max lens travel is depending on the 
deflection unit, and can be viewed at Edit > Change Header. For most lens translators, it’s 
11mm. The distance between the lines is set via the Line spacing. If the control value for the z 
axis is outside the markable range, the line will not be marked. This problem can be compen-
sated by moving the position of the lens in the lens translator. For values smaller than the mini-
mum (-524288), move the lens towards the laser, for values larger than the maximum (524287) 
towards the scanner. 
By variating the offset, the best z correction values can be determined. The most focused line 
defines the offset. See chapter 5.4.2 for how to apply the measured values. 

 

The length of the marked line can be influenced by the line length scale. A scale of one results in 
the largest lines still fitting into the scan field. 
Horizontal marks the lines horizontally instead of vertically. 
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6.4 3D Mode 
There are two approaches for calibration a *.fc3 correction file with multiple layers. 
For the Single layer mode, only a single layer is measured and the resulting corrections will be 
applied to all layers. The desired z position can be set without restriction. This mode can be use-
ful if the distortion is the same for every z height. 
If the distortion is different for multiple z heights, the Multi Layer mode should be used. In this 
mode, the measurements will be done on several layers and the resulting corrections will be in-
terpolated in-between the layers. For a good result, at least the most top and bottom layers 
should be included. Otherwise the calibration data has to be extrapolated which could result in a 
loss of accuracy. The desired layers can be chosen be clicking on the corresponding check-
boxes. 
Please note that it is not possible to apply the corrections to a single layer only. If only one layers 
is checked in the multi-layer mode, the correction will still be applied to all layers. 
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6.5 Setting marking parameters 
The object depending marking parameters can be set in the scanner and laser boxes. For load-
ing the vales the cards has used last, the Load presets from card button can be pressed. 

 

All system parameters like the laser polarity etc must be set via the SP-ICE-3 config tool. If the 
card has already been used since the last reboot or the config is stored on the card, the system 
should already been configured. 

6.6 Mark pattern 
Depending on the type of laser, the laser has to be armed before the start of engraving. If the 
Arm Laser button (fire symbol) is black, the laser is not armed and the pilot (if availible) is active. 
If the button is pressed, it will turn red, arm the laser and deactivate the pilot. By pressing the 
button again, the laser will be disarmed. 

 

 

Fig. 5: Update     Arm     Mark     Abort 

Pressing the Mark button (play symbol) will mark the patterns.  
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For each pattern, a message with the z position will be shown. 

 

While the marking is in progress, the Laser Active sign in the status bar is red.  

 

As soon as the marking is finished, the sign will turn green. 

 

6.7 Create new measurement table 
After the marking is done, a new measurement table, with the configuration used for marking, 
can be created by clicking the New Measurement Table button. 
See chapter 5.4 for how to enter the measured errors. 
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7 COMMAND LINE 

7.1 Correction file generation 
For fc3, gcd or pc3 generation via script, a command line interface has been implemented. 
The generated file will be saved in the same path as the input file and, despite of the ending, will 
be named same. 
If a file with the same name is already existing, it will be overwritten without asking. 
In case of the correction values exceeding the field, they will be clipped automatically. 

7.1.1 Fc3 generation 
For fc3 generation the following arguments are expected in this order: 
 fc3 
 txz filename (with path) 
 optional config file name: default values are :  

XYMaxGalvoAngles = 22.5, MaxLensTravel = 11 
In case of focus shifter, MaxLensTravel is calculated as 1048575 / taxiscalfactor. 

 optional rows, default value = 257 
 optional columns, default value = 257 
 optional layers, default value = 17 

7.1.2 Gcd generation 
For gcd generation the following arguments are expected in this order: 
 gcd 
 txz filename (with path) 
 optional config file name: default values are :  

XYMaxGalvoAngles = 22.5, MaxLensTravel = 11 

7.1.3 Pc3 generation 
For pc3 generation the following arguments are expected in this order: 
 pc3 
 txz filename (with path) 
 optional rows, default value = 257 
 optional columns, default value = 257 
 optional layers, default value = 17 
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7.2 Apply measurement table 
The measurement table can be applied to a correction file with or without sub field. 

7.2.1 Without sub field 
The following arguments are expected in this order: 
 applyError 
 correction file name (*.gcd, *.fc3 or *.pc3) 
 measurement table file name (see 5.11 for file format) 
 optional new correction file name 
If the new name is not set, the original file will be overwritten. 
Sample including new file name (quotes are only necessary if path contains whitespaces):  
MultiPointEditor.exe applyError “correction.fc3” “measurements.mtf” “newFileName.fc3” 

7.2.2 With sub field 
The following arguments are expected in this order: 
 applyErrorSubfield 
 correction file name (*.gcd or *.fc3) 
 measurement table file name (see 5.11 for file format) 
 sub field size X [µm] 
 sub field size Y [µm] 
 sub field offset X [µm] 
 sub field offset Y [µm] 
 optional new correction file name 
If the new name is not set, the original file will be overwritten. 

7.3 Apply bit error 
A table with error in bit can be applied to the correction file. The values will be interpolated to 
match the dimensions of the correction file and then be added to the correction values. 
Expected format: 
 

; Layer Row Column OffsetX [bit] OffsetY [bit] OffsetZ [bit] Offset4 [bit] Offset5 [bit] 
0 0 0 0 0 0 0 297.886 
0 0 1 0 0 0 0 500 

 

The following arguments are expected in this order: 
 applybiterror 
 correction file name (*.gcd, *.fc3 or *.pc3) 
 bit error table file name  
 optional new correction file name 
If the new name is not set, the original file will be overwritten. 
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7.4 Logging 
A log file is stored at  
%programdata%\RAYLASE\Multi Point Editor\Logs\MultiPointEditorConsole.log.  
It contains the parameters the program got called with and, if occurred, the error messages. 

8 COMPATIBILITY NOTES 
The herein described methods apply to the following component(s): 
 Multi Point Editor version 7.0.3 and later 
 All RAYLASE standard and UHSS scan heads 
 SP-ICE-3 v1.31 and later (only for the marking part) 
Note the compatible SP-ICE-3 Firmware Version as mentioned in the downloaded file name, for 
example: 

 

9 DOCUMENT CHANGE HISTORY 
 

Rev Date Valid from MPE 
version 

Description 

1.1.14 2021-09-01 8.0.19 Transfer from Application Note to User Manual, new layout;  
New: chap. Installation and License, Compatibility note;  
Removed: List of compatible SP-ICE-3 versions 

1.1.15 2022-10 8.0.26 Chapter 2: Installation and License (RLPI) 

10 KNOWN ISSUES 
 Changing amount of magnification levels is not supported  



 

Head office:  
RAYLASE GmbH 
Wessling, Germany 
✆ +49,8153.8898-0 
✉ info@raylase.de 

China subsidiary: 
RAYLASE Laser Technology (Shenzhen), Ltd. 
Shenzhen, China 
✆ +86,755.2824-8533 
✉ info@raylase.cn 

USA subsidiary: 
RAYLASE Laser Technology Inc. 
Newburyport, MA, USA 
✆ +1.978.255-672 
✉ info@raylase.com 
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